Menu

File Menu

New Scene Closes current scene, starts editing a new empty scene.
Load Scene Opens a existing scene from disk file.
Save Scene Saves current editing scene to disk.
Save Scene As Saves current editing scene to disk with a new filename.
Save a Copy As Saves a copy of current editing scene.
Save Light Maps Saves lightmap data to bmp files. If no lightmap in current scene, this menu item will be grayed.
Cut Screen Saves viewport image to bmp file.
Load Mesh... Clears all surfaces in current scene, then loads mesh from .tri file and generates surfaces.
Append Mesh Loads mesh from .tri file and generates surfaces.
Import... Imports each kind data ( mesh, material, light, texture... ) to current scene from other format file.
Export... Exports each kind data ( mesh, material, light, texture... ) to other format file.
Exit Quits the application.


Edit Menu

Undo Reverses the effect of the last action.
Cut Cuts the selection and moves it on the Clipboard.
Copy Copies the selection to the Clipboard.
Paste Inserts Clipboard contents.
Instanced Paste Inserts Clipboard contents to scene as instancing.
Delete Deletes the selection.
Calculate Light Maps Calculates ray-tracing lighting and builds lightmaps.
Calculate Lighting For Selection Calculates ray-tracing lighting for selection and updates corresponding lightmaps.
Radiosity Calculates radiosity lighting, and cumulates to lightmaps.
Batch Radiosity Batch calculates radiosity lighting
Caustic Calculates caustic effect for selection.
Ambient Occlusion Calculates ao lighting, and merges to lightmaps.
Hold Takes a snapshot of current scene's contents.
Fetch Replaces current scene's contents by snapshot that created by Hold.
Move Accurately offsets object in 3D Space.
Rotate Accurately rotates object in 3D Space.
Scale Accurately scales object in 3D Space.
Combine Selected Surfaces Makes selected multi-surfaces to one surface. All selected surfaces must be coplanar, or will incur incorrect lighting.


Select Menu

Select None Selects nothing.
Select All Selects everything in scene.
Select Invert Selects everything that not in current selection.
Select Surfaces By Texture To do this, you should first select one surface ( Sample Surface ), then do this command, will select all surfaces that have same texture with the Sample Surface.
Select Objects By Instance ID To do this, you should first select one instanced object ( Sample Object), then do this command, will select all objects that have same instance id with the Sample Object.


Associate
Menu

Group Binds selected objects to a group.
Ungroup Breaks up selected group.


Create
Menu

Static Mesh Creates a Static Mesh object from .tri file.
Mobile Creates a Mobile object from .tri file.
Multiple Mobiles Creates multiple Mobile objects from multi-meshs .tri file. A tri file can includes multiple meshs, this command will respectively creates mobile for every mesh.
Skin Mesh Creates a Skin Mesh object from .tri file.
Section To do this, you must first select some surfaces that bound a 3D space area ( e.g. a room's four walls + floor + ceiling ). Then do this command, will create a Section.
Sound Inserts a sound resource to scene.
Script Creates a script resource.
Bones Animation Creates a Bones Animation from .ani file.
Terrain Creates a Terrain object.
Ocean Creates an Ocean object.


View Menu

Main Toolbar Show or hide the Main Toolbar.
UV Toolbar Show or hide the UV Toolbar. UV Toolbar is for adjust texture coordinate of surface's vertices.
Selection Toolbar Show or hide the Selection Toolbar. Selection Toolbar is for create/select selection.
Creation Toolbar Show or hide the Creation Toolbar.
Status Toolbar Show or hide the Status Toolbar.
Properties Panel Show or hide the Properties Panel. Properties Panel is for change object's parameters, and texture/material/shot operations.
Animation Panel Show or hide the Animation Panel. Animation Panel is for edit animation.
Console Window Show or hide the Console Window. In Console Window, you can do some inner commands of 3D engine that behind Awakening.
List Objects... Show the Objects List Window. This window list all the objects of current scene, also can select objects.
Sounds List... Show the Sounds List Dialog. This Dialog list all sounds of current scene, also can new/delete sound.
Scripts List... Show the Scripts List Dialog. This Dialog list all scripts of current scene, also can new/delete script.
Bones Animations List... Show the Bones Animations List Dialog. Also can new/delete/edit Bones Animation in this dialog.
Script Variables List... Show the Script Variables List Dialog.
Edit User Script File... Edit User Script File. If you haven't save scene never, program will prompt save file first.
Show > Toggles show and hide.
Select Object > Options of drawing selected object.
Fill Mode > Options of drawing mesh.
Hide Hides selected objects.
Unhide... Unhides hidden objects.
Unhide All Unhides all hidden objects.
Orthogonal Projection Toggles orthograph and perspective for viewport.
Full Screen Toggles full screen and window mode for viewport.


Tool
Menu

Plugins Lists all available plugins.
Align Objects Actives aligning mode.
Move to the front Moves the current selection to the front of camera.
Arrange Scene Optimizes scene and clean up invalid objects ( e.g. a zero area surface will be treated as invalid object ), also build collision data.
Whole scene transform Transforms whole scene, currently supports surfaces, static meshs, terrains(no rotation) and mobiles.
Install Scene Saves current scene to specific folder and copys all resource. This function is for publishing your work.
Create Web3D Page Creates a html file for Web3D.
Play Scene Runs current scene in Winds3D Player.
Save to tri file... Saves selected object to a .tri file.
HDR Format Convert... Converts HDR image's format.
Grab Cube Map... Grabs a Cube Map at current camera position.
Toggle Soft/Hard Shadow Switchs Soft Shadow / Hard Shadow, this actually modify the "effects\include\shadowdef.fx".


Options Menu

Change Device... Selects rendering device and rendering mode.
Light Map... Shows Light Map Options Dialog.
Viewport... Shows Viewport Options Dialog.
Environment... Shows Environment Options Dialog.
Miscellaneous... Shows Miscellaneous Options Dialog.
Reset All... Shows Reset Options Dialog.


Help
Menu

Contents Shows help contents of Awakening.
About Awakening... Displays program information.